Site Index
   Home
   File Upload
Google

Transfer Site
Main Site

EVM5502 FlashBurn Utility Overview

FlashBurn is a utility included with Code Composer Studio that can be used to program code and data into the on-board Flash on the EVM5502. One of the most common uses for FlashBurn is to take user code that has been debugged with Code Composer and program it into the Flash so that the board will boot it and run in standalone mode when it is powered up independently of the debug environment.

FlashBurn does not ship with standard configurations of Code Composer. However, it is available free of charge through Code Composerís on-line Update Advisor. Use Update Advisor to download and install the FlashBurn install program.

This section describes how to burn a demo into Flash using some pre-built example files, more detailed instructions on using FlashBurn can be found in the "FlashBurn Utility" section of the Code Composer Studio Online Help. The demo and related files are in located in

   c:\ti\boards\evm5502\examples\demo

The following sequence outlines programming the demo into Flash:

  • Create a bootloader image of the executable file in ASCII hex file format (demo.hex).

  • Launch Code Composer Studio to allow access to the integrated tools.

  • Load the configuration document (demo.cdd) that tells FlashBurn what to burn into Flash.

  • Erase the Flash with FlashBurn.

  • Program the Flash with FlashBurn.


Programming the Demo with FlashBurn

To start the FlashBurn process, launch Code Composer Studio. Now launch FlashBurn by clicking Tools -> FlashBurn.

FlashBurn will now launch. Use File -> Open to open the sample FlashBurn configuration document

   c:\ti\boards\evm5502\examples\demo\demo.cdd

You should see a window that looks like this:

The important fields are the "File To Burn" field at the top and the "FBTC Program File" at the bottom. The "File To Burn" field specifies the .hex file to program into Flash, in this case the hex file in the demo directory:

   c:\ti\boards\evm5502\examples\demo\demo.hex

The "FBTC Program File" is a piece of code that FlashBurn executes on the EVM5502 to manipulate the Flash. It is supplied with the EVM5502 examples in:

   c:\ti\boards\evm5502\flashburn\FBTC55.out

These settings are pre-configured in the demo.cdd file and only need to be changed if the base install directory is not c:\ti. If c:\ti is not the install directory FlashBurn will give you an error message because the paths above do reference anything. Hit cancel in response to the error dialog to make FlashBurn give you a chance to edit the fields.

Select Program -> Erase Flash option under the Program menu to erase the Flash. It should take about 10 seconds. Now select Program -> Program Flash option to start programming the Flash. After about 3 seconds the procedure should be complete. Exit out of FlashBurn and Code Composer, unplug power to the EVM5502 then plug the power back in. The demo will now start running automatically (as long as your emulator is unplugged).


Generating a Bootable Hex File

This section describes the steps necessary to convert the demo.out file into the demo.hex file needed by FlashBurn as an example you can apply to your own programs. You do not have to perform these actions simply to put the demo in Flash if you have an existing hex file already.

A hex file contains binary data at the addresses you specify in a file format readable by the Flashburn utility and other Flash programmers. The utility requires several flags to select the proper output format. In this example, the flags are stored in the file demo_hex.cmd which is a text file that can be edited to suit other purposes. The key flags are:

Flag Description
-a Select ASCII hex file format for output
-parallel16 Generate output for a 16-bit wide Flash device
-boot Enable boot table generation
-v5510:2 Processor version, use 5510 even through you have a 5502

To convert the file Debug\demo.out into the hex file demo.hex using the flags stored in demo_hex.cmd, open a DOS Command Prompt window and type the following:

   cd c:\ti\boards\evm5502\examples\demo
   c:\ti\c5500\cgtools\bin\hex55 demo_hex.cmd

The file demo.hex is now ready for programming with FlashBurn. For more details on the hex utility, please see the Code Composer help under Code Generation Tools -> Hex Conversion Utility.

©Copyright 2002-2011 Spectrum Digital, Inc. All Rights Reserved.